?

Log in

No account? Create an account
Хвостат Хвостатыч
13 January 2013 @ 11:28 pm






Приветствую!




sittin' on yer cisco switch | floodin' yer packetz


Меня зовут Денис, и я системный инженер администратор.
Этот ЖЖ создан в качестве рабочего блокнота для (около)айтишных записей и обмена опытом с коллегами.
Во-первых, для противодействия собственному склерозу, а во-вторых, для приведения мыслей в порядок.

Чему здесь быть:
- рабочие заметки
- обмен опытом
- howto’шки
- хаки и лайфхаки
- вопросы к читателям
- ссылки
- живое общение
- профессиональный юмор

Твиттер имеется:
https://twitter.com/hvostat

Инстаграм наличествует:
http://instagram.com/hvostat

Основные теги:

Windows, Windows Server - Windows десктопный и серверный.

juniper, JunOS - всё про Juniper вообще и JunOS в частности.

linux, CentOS, Debian - красноглазое красноглазие, пингвины, бубны оптом.

утипусечка - железо. Я очень люблю работать с разными электронными штуковинами, и с удовольствием об этом напишу.

софт - всё, что не железо.

бНОПНЯ - вопрос к аудитории.

планета Черезжопия, это не надо - иллюстрация того, как делать не надо.

рекомендация - посоветую, какое железо или софт лучше использовать, исходя из собственного опыта.

юмор - чего-нибудь похихикать.

жизненное - о реальной жизни.

hvostat.log - про вашего покорного слугу.

Правовая оговорка и письменный отказ от ответственности:
Все упоминаемые в Блоге торговые марки и товарные знаки принадлежат их владельцам.
Автор не несет ответственности и не предоставляет гарантий в связи с публикацией фактов, данных, результатов и другой информации в данном Блоге.
Все инструкции и/или гайдлайны, написанные в данном Блоге НЕ ЯВЛЯЮТСЯ руководством и/или рекомендацией к действию.
Автор не несет ответственности за возможное нанесение ущерба любого рода, прямого либо косвенного, которое произошло вследствие выполнения инструкций и/или гайдлайнов.
Все истории, места, события и герои вымышлены. Любые совпадения с реальными личностями и событиями случайны.


//Да, на фотографии - моя кошка. Зовут Жыслая. И на юзерпике - тоже она. Язычёк настоящий, гарнитуру прифотошопил.
//Хвостат Хвостатыч - потому что в своё время я таки был хвостат.

__
 
 
Хвостат Хвостатыч
18 September 2019 @ 09:08 pm
Проблема:
При работа с git-ом через медленный канал связи и/или VPN, при попытке выполнить git clone особо жирной репы, получаем 1-2 минутную "тупню", потом следующий отлуп:
Den@host:/bin# git clone --recursive https://hvostat.cat/git/fatcat.git
Cloning into 'fatcat'...
error: RPC failed; curl 52 Empty reply from server
fatal: the remote end hung up unexpectedly

Решение
git clone http://hvostat.cat/git/fatcat.git --depth 1
$ cd fatcat
$ git fetch --unshallow

__
 
 
 
Хвостат Хвостатыч
Проблема:
После обновления версии OpenVPN до 3.0.3 не удаётся подключиться к OpenVPN серверу.
НА сетевом уровне проблем нет, конфигурация сервера не менялась, сертификаты в полном порядке, унитаз приносил, жопу показывал. ©

Решение:
Реимпортировать конфиг.

__
 
 
Хвостат Хвостатыч
Задача:
Настроить роутинг таким образом, чтобы клиенты удаленного офиса ходили в интернет через "ядро" сети в датацентре/головном офисе.

Условия:
SRX-HEAD - роутер в "центре".
SRX-BRANCH - роутер в филиале.

Решение:
1) В центре и филиале создаём security-zone "VPN".
2) Протягиваем route-based IPSec-VPN из филиала в центр, виртуальные интерфейсы st0.n определяем в зону "VPN". Убеждаемся, что пакеты ходят.
3) В центре пишем source-NAT приблизительно таким образом:
set security nat source rule-set vpn-branch from zone vpn
set security nat source rule-set vpn-branch to zone internet
set security nat source rule-set vpn-branch rule vpn-to-internet-src-nat match source-address 0.0.0.0/0
set security nat source rule-set vpn-branch rule vpn-to-internet-src-nat match destination-address 0.0.0.0/0
set security nat source rule-set vpn-branch rule vpn-to-internet-src-nat then source-nat interface
4) Дописываем соответствующую security policy.
5) В филиале создаём firewall filter на интерфейсе, который смотрит в локальную сеть 192.168.177.0/24, примерно такой:
set firewall family inet filter vpn-head term 1 from source-address 192.168.177.0/24
set firewall family inet filter vpn-head term 1 then routing-instance vpn-head
set firewall family inet filter vpn-head term 2 then accept
6) Навешиваем фильтр на интерфейс:
set interfaces ge-0/0/5 unit 0 family inet filter input vpn-head
6) Создаём routing-instance типа "forwarding", который будет трафик филиала отправлять нахер в центральный роутер:
set routing-instances vpn-head routing-options static route 0.0.0.0/0 next-hop st0.n
set routing-instances vpn-head instance-type forwarding
7) Создём rib-группу для обмена маршрутами:
set routing-options rib-groups global-rib import-rib inet.0
set routing-options rib-groups global-rib import-rib vpn-head.inet.0
set routing-options interface-routes rib-group inet global-rib
8) ???
9) PROFIT!!!

PS: Опционально - настроить RPM Probe + ip-monitoring и последующее переключение routing-instance на случай падения VPN-канала.
(чтобы коллеги не остались без инета)

__
 
 
 
Хвостат Хвостатыч
10 September 2019 @ 09:58 pm
В далёком 2010-м году купил компьютерных "потрошков" и собрал рабочую станцию. Матплата - честный Intel, DH55HC с "камнем" Core i5-650.
Проработал на ней около пяти лет, изучив тонны интересных штук и переделав сотни лабораторных работ.
Прогресс не стоит на месте, да и а руки у кодописов прямее не становятся - проапгрейдился.

А из этого комплекта сделал домашний сервер/vmhost - благо, проц полностью поддерживает VT-x и VT-d.

Прошла еще пара лет.
За очень хорошую цену мне отдали HP ProLiant Microserver Gen8.
650-й был отправлен на заслуженный отдых.

Возник вопрос - а что с ним делать? Выбросить? Жалко. Продать? За копейки. Подарить? Да не нужен он никому.
Так и стояла в углу машина, проходя процесс естественного состаривания.

Внезапно. klink0v задал неожиданный вопрос:
- Дэн, а у тебя случайно нет матплаты под сокет 1156? Именно ШЕСТЬ.
- ВНЕЗАПНО, есть, - ответил я.

Сергеич™ сегодня заехал и забрал железку.

Я очень-очень рад, что она еще послужит хорошему человеку.

__
 
 
 
Хвостат Хвостатыч
07 September 2019 @ 01:24 am
Два месяца назад nVidia выпустила рефреш/ремастер старого-доброго второго квейка, но с обновленным графическим движком на основе трассировки лучей в реальном времени.

Хвостатыч скачал, запустил, прошел пару эпизодов и имеет сказать следующее:

- Это - прекрасно! Графика в целом смотрится НАСТОЛЬКО свежо и красиво, что порой просто любуешься привычными локациями и не хочешь никуда бежать и никого убивать.
- Время суток можно динамически изменять. Более того, можно поставить синхронизацию игрового времени с временем компьютера. Также, внутриигровое время можно ускорить в 12 раз, чтобы наблюдать смену дня и ночи прямо "на лету".
- На некоторых уровнях по небу пролетают самолёты. Если выставить время на "ночь", то свет их двигателей будет кратковременно освещать часть уровня.
- Добавлено одно оружие: "flare gun". Выстреливает святящуюся шашку. Почему-то расходует гранаты.
- Стекла честно отражают и преломляют. Вода - аналогично.
- Пуск ракеты в темном коридоре и последующее наблюдение совершенно корректных теней от объектов окружения и отражений света её двигателя в первый раз вызывает отвал башки. Шар BFG10K - аналогично.
- К сожалению, кровь и отметины на стенах от попадания пуль/снарядов не реализованы.
- Грибообразный взрыв из оригинальной игры заменили на спрайтовый. Зачем - непонятно.
- Модели врагов - без изменений.
- Увеличено разрешение текстур, часть текстур заменены. К сожалению, эта часть выполнена халтурно, например лава похожа на что угодно, кроме лавы. Более того, заменены текстуры моделей врагов - некоторым добавлены светящиеся глаза. Выглядит отвратительно и дешево.
- На уровне "нижние шахты" прожилки минерала под названием стидиум (steedium) (почему спустя 22 года я это помню?!) сделаны светящимися. Бегать по полутемной локации и наблюдать мерцающие голубые блики на оружии/объектах/воде - изумительно.
- Зачем-то заменены модели оружия (как item-ов так и моделей в руках игрока) - RailGun и BFG10K. Причем, модели откровенно некрасивые.
- Участникам клуба ностальгирующих - обязательно к ознакомлению и/или перепрохождению.

PS: Не перепутайте, это именно Quake 2 RTX, а НЕ Quake2_VKPT.

__
 
 
 
Хвостат Хвостатыч
01 September 2019 @ 12:18 pm


_
 
 
Хвостат Хвостатыч
19 August 2019 @ 11:34 am
Рядом с метро Сходненская есть парк Северное Тушино.
И на берегу Москвы-реки еще в 2006 году поставили подводную лодку проекта 641Б и сделали из нее музей.



Вчера сходили туда с мудрейшим klink0v.

Лирическое отступление.
У каждого человека есть определенное внутреннее везение.
Кому-то везёт на деньги. Кому-то везёт в любви.
Как показывает практика - мне в жизни просто фантастически везёт встречать хороших и интересных людей.

Так вот. Купили мы билеты, заходи в 641-ю.
Ну и покуда экскурсию мы не заказывали, рассказывал я.
"Добрый день дамы и господа, мы находимся в первом, торпедном отсеке, впереди вы видите шесть торпедных аппаратов калибра 533 мм, бла бла бла"

Заходим во второй отсек. Я продолжаю чего-то рассказывать, а рядом стоит какой-то дядька.
И он вначале меня начал поправлять, а потом уже сам стал рассказывать.

Познакомились, разговорились.

Его зовут Олег, и оказалось, он - настоящий подводник. Служил на атомной подводной лодке!!! (вначале сказал, что механик, потом уточнил, что оператор ГЭУ)
Короче, он нам эту 641-ю просто блин на гайки разложил!!! Три часа рассказывал всё про все устройства, системы и механизмы.
Я-то большую часть знал, а вот друзья слушали раскрыв рты!
"Он провёл для нас не просто экскурсию, а экскурсиющщщу!" ©
Бонусом - несколько веселых историй про службу, в том числе крайне забавную Whiskey on the rocks, она же «Шведский комсомолец».

Олег живёт в Питере и "приехал в Москву с женой всего на пару дней, а сюда привёл, чтобы показать, что такое подводная лодка".
Тут мы и встретились. Согласитесь, везение - просто фантастическое!

Пару слов про музей.
Лодку очень серьезно раскурочили ради музейности: для посетителей доступна только третяя палуба, центральный пост, похоже, удалён; на всей лодке порезана значительная часть кабелей и трубопроводов, из трех дизелей остался один, освещение переделали, итд.

__
 
 
 
Хвостат Хвостатыч
Съездили с мудрейшим klink0v, заслушали лекцию про "сушку".

Господа. Уважаемые сэры. ЭТО ЖИР.
Это два часа концентрированного ЖИРА.

Выступал спикер ОКБ Сухого Вячеслав Николаевич Зенкин - зам. главного конструктора.
Рассказывал всё очень детально, показывал много чертежей и фото - от ранних прототипов и до современного Су-35С.

Ну и традиционно - ответы на вопросы слушателей.
Наверное, это был тот редкий случай, когда спикер ответил на ВСЕ вопросы, опять же, очень подробно и обстоятельно.

Единственное, что - не смог ответить на мой же вопрос по ЭДСУ, но это нормально - он - "прочнист" (ЕМНИП), а вот человек, который МОГ ответить - уже мало того, что давно уволился из ОКБ, к огромному сожалению - ещё и умер. C'est La Vie.

Короче - кто обломался приехать - тот сколопендра.

__
 
 
Хвостат Хвостатыч
14 August 2019 @ 10:58 am
Коллеги, недоброе утро!

Тут в RDP очередная уязвимость образовалась:
CVE-2019-1182

Уязвимость ОЧЕНЬ серьезная - "Remote Code Execution"

Уязвимы ВСЕ "форточки" от Windows Server 2008 R2 до Windows Server 2019 и, само собой, их клиентские версии.

Срочно накатывайте августовский набор обновлений безопасности!

__
 
 
 
Хвостат Хвостатыч
12 August 2019 @ 11:25 am


Пятое лето подряд собирались с друзьями в Кубинку, посмотреть на танки вживую.

И вот, вчера наконец-то собрались!

Что я вам могу сказать - "на троечку". С минусом.

Забегая наперёд - рядом строят огромнейший парк "патриот" - и вроде как всю технику из самой Кубинки скоро перевезут именно туда.

Сам музей представляет собой 7 павильонов типа "бокс" (ангар?) для тяжелой техники - такие были на каждой военной базе времен СССР.
Длинные такие "коробки" 80х20 метров с воротами по длинной стороне.

В чем минусы такого размещения?

Танки расположены как коровы в коровнике - справа и слева от узкого центрального прохода, причем плотненько так.
Посетителям даётся возможность рассмотреть экспонаты только спереди и немного сбоку. Причем, "сбоку" - совсем немного.
Подойти вплотную нельзя: ограждено ленточкой, а рядом таблички с угрожающей надписью: "НА ТЕХНИКУ ЗАЛЕЗАТЬ СТРОГО ЗАПРЕЩЕНО!" и конечно же "РУКАМИ НЕ ТРОГАТЬ!"
Блять, но почему??? ЭТО Ж СУКА ТАНК!!!

В одном из павильонов вообще было прекрасное: один БМП стоял к посетителям ЖОПОЙ, и еще и был закрыт стеклом.
Мы недоумевали и шутили, что, наверное, это - секретный БМП. С секретной жопой!

Освещение - отвратительное: сверху висит буквально десяток тусклых ламп.
Окна - есть, но они только мешают: яркий свет сзади техники в полутёмном ангаре слепит.

Из 7-ми павильонов работало 6.
Почему-то был закрыт "Техника Японии и стран Европы". На дверях - никаких пояснений для посетителей, зато пломба! Это - на случай, если вдруг танк спиздят?

Надписи на табличках скудны: в среднем выглядят примерно так: "Танк "объект-100500", разработан в СССР в 1987 году в НИИ СекретТрансМаш, конструктор - М.Пупочек, двигатель БЛЯ-23М, 100500 л.с., масса - 48.8 тонн, скорость 55 км/час, вооружение - пушка 3А23М-бис, калибра 88 мм, плавает."

Офигенно! А какую задачу решал конструктор? С какими сложностями столкнулся? А почему данный танк так и не пошел в серию?

Теперь давайте помечтаем. Чего бы очень хотелось лично мне:
- разместить танки свободнее и обеспечить обзор со всех сторон
- нормально осветить
- поднять уровень пола вокруг танков на полметра-метр, потому что танк - штука большая (спасибо Кэп) и при взгляде снизу видны далеко не все детали (особенно - детям)
- прилепите, блин, на таблички QR-коды со ссылками на статьи! Можно даже три кода - "базовая информация" коротко и максимально популярно, "расширенная информация" для интересующихся ну и тонну чтива "для гиков".
- ну и в мире с розовыми пони - для смартфонов - приложение с AR, чтобы смотреть разрезы.

Из плюсов: атипичный охранник. Невероятно вежливый, корректный и даже заботливый.

Цена вопроса: 400 рублей "взрослый" билет + 200 рублей парковка.

Такие дела.

__
 
 
 
Хвостат Хвостатыч
На всякий случай обращу ваше внимание: ФСБ получила право на разделегирование доменов.

Слава Тюрингу, только в России. И только *.ru *.su и *.рф

Сухим юридическим языком это звучит так:
"Мера по разделегированию домена отличается от блокировки сайтов через судебное решение и Роскомнадзор и при этом
позволяет значительно быстрее ограничить доступ к ресурсу."

Что делать:
- создать четную запись у любого другого регистратора доменов в Европе/Америке и передать ваш домен туда.
- не использовать домены *.ru *.su и *.рф

ИМХО, сделать это нужно чем быстрее, тем лучше.

__
 
 
 
Хвостат Хвостатыч
Задача:
Пропускать только тех клиентов на веб-сервер/сервис, которые обладают соответствующими сертификатами.

Решение:
0) Генерируем клиентский сертификат на нашем СА и выдаём, например hvostat_client.pfx клиенту.
1) Записываем наш CA-сертификат на веб-сервер, например в /etc/pki/hvostat_ca.crt
2) В конфиге nginx, среди прочего добавляем примерно следующее:
server {
listen 443 ssl;
server_name example.com;
ssl_certificate /etc/pki/example.com.crt;
ssl_certificate_key /etc/pki/example.com.key;
ssl_client_certificate /etc/pki/hvostat_ca.crt;
ssl_verify_client on;
}

__
 
 
Хвостат Хвостатыч
02 August 2019 @ 06:00 pm
— Простите, а клуб ностальгирующих здесь находится?
— Да, но он уже не таков, как прежде...



© Автор неизвестен

__
 
 
 
Хвостат Хвостатыч
01 August 2019 @ 09:27 pm
Ситуация:
После замены виртуальных жестких дисков и последующей попытке запустить виртуальную машину, получаем отлуп следующего вида:
"An error occurred while attempting to start the selected virtual machine(s).
VM-100500 failed to start. (Virtual machine ID BLA-BLA-BLA)
VM-100500 Microsoft Emulated IDE Controller (Instance ID OZAZA): Failed to Power on with Error ‘General access denied error’ (0x80070005). (Virtual machine ID BLA-BLA-BLA)
VM-100500: IDE/ATAPI Account does not have sufficient privilege to open attachment D:\Hyper-V\Virtual hard disks\VM-100500-01.vhdx. Error: ‘General access denied error’ (0x80070005). (Virtual machine ID BLA-BLA-BLA)"

Причина:
Нет разрешений для объекта виртуальной машины вида "полный доступ" для файла виртуального жесткого диска.

Лечение тривиальное:
1) Узнаём имя виртуальной машины и путь к *.VHD/*.VHDX файлам дисков.
2) Узнаём Virtual machine ID. Для этого вводим команду в PowerShell:
Get-VM -Name VM-100500 | Select-Object VMID
Получим ответ вида:
12345678-90ab-cdef-0123-4567890abcfe
3) Далее, "надеваем на голову" файлам нужные права:
icacls "D:\Hyper-V\Virtual Hard Disks\VM-100500-01.vhdx" /grant 12345678-90ab-cdef-0123-4567890abcfe:F
4) Повторить для всех файлов виртуальных дисков.

__
 
 
Хвостат Хвостатыч
31 July 2019 @ 12:26 pm
,,,=^.^=,,,

__
 
 
 
Хвостат Хвостатыч
26 July 2019 @ 10:30 am
Уважаемые друзья и коллеги.
Если вы читаете это сообщение, то это значит следующее:
1) Вы умеете читать.
2) Сегодня пятница.
3) Сегодня день сисадмина.



С чем вас и поздравляю!

__
 
 
 
Хвостат Хвостатыч
22 July 2019 @ 02:40 pm
50 лет назад Армстронг ступил на поверхность Луны.

Почитать про устройство ракеты, кораблей, а также описание экспедиций можно тут:
http://www.e-reading.club/bookreader.php/66469/Shuneiiko_-_Pilotiruemye_polety_na_Lunu.html

__
 
 
 
Хвостат Хвостатыч
02 July 2019 @ 05:34 pm
Задача: по прошествии пяти лет продлить срок действия корневого сертификата Microsoft CA.
Нюанс: ключевую пару оставить прежней.

Решение:

1) Заходим на CA-сервер
2) Запускаем командную строку.
3) Вводим следующее:
certutil -renewCert ReuseKeys
4) Презапускаем CA.
5) ???
6) PROFIT!!!

__
 
 
Хвостат Хвостатыч
14 June 2019 @ 11:04 am
Недавно покупал кое-какую мелочёвку электронную на барахолке.

Разговорились с продавцом.

- Я, говорит, специалист по силовой электронике.
Сейчас занимаюсь тем, что "ласточки" обслуживаю и ремонтирую.
- Ооо, - заинтересовался я. И как? Хорошие? Надежные?

Он на секунду задумался:
- Те, которые были оригинальные немецкие - отличные. А те которые уже отечественные, - он сморщился, будто съел ломтик лимона, - ПИЗДЕЦ ГОВНО!

__
 
 
 
Хвостат Хвостатыч
10 June 2019 @ 11:20 pm
Коллеги, внимание!

У кого Exim НЕ обновлен до версии 4.92 - НЕМЕДЛЕННО обновитесь!

CVE-2019-10149.

Потенциально уязвимы несколько миллионов серверов по всему миру, уязвимость критическая: (CVSS 3.0 base score = 9.8/10)

Прямо сейчас идет активное заражение!

Подробнее тут:
https://habr.com/ru/post/455598/

__
 
 
Хвостат Хвостатыч
24 May 2019 @ 09:49 pm
Теперь почётное звание "сракорукие пидарасы" переходит к Apple.

Внимание всем, у кого макбуки и/или макпро.

Примерно позавчера Apple выпустила обновление операционной системы Mojave с номером 10.14.5.
Симптоматика: система не грузятся дальше «яблока».

Решение, в простом случае:
1) Загрузиться в режиме восстановления
2) Ввести следующее:
diskutil apfs unlockvolume disk1s1, где disk1s1 — это основной раздел.
нажимаем Enter.
Если диск зашифрован, вводим пароль.
3) Восстанавливаем загрузчик:
Вводим:
diskutil apfs updatePreboot disk1s1
По завершению работы команды выходим из Терминала
4) Перезагружаем компьютер.

Решение, в сложном случае:
Обратиться в СЦ.

__
 
 
 
 
 
Хвостат Хвостатыч
10 May 2019 @ 08:08 pm
Еще один микрорецензий прочитанных книг псто.

Патрик Александер - "Смерть раненого зверя с тонкой кожей" - хорошо. По мотивам книги снят фильм "Профессионал" с Бельмондо. На удивление, довольно близко к оригиналу. И так же грустно.

Малколм Гладуэлл - "Гении и аутсайдеры" - отлично. Книга о том, почему кто-то (с виду) легко добивается успеха, а кто-то нет. Именно из этой книги берутся волшебные "10 000 часов", отработав которые человек становится профессионалом в своём деле. Рекомендую.

Карл Саган - "Контакт" - отлично. О девушке-радиоастрономе, которая получила сигнал внеземной цивилизации. По книге снят одноименный фильм. Разница в морали - в книге она в 1000 раз глубже.

Джаспер Ффорде- "Оттенки серого" или "Полный вперед назад" - хорошо/отлично. Антиутопия. ~2500-е годы. На земле произошел некий катаклизм, после чего природа сильно изменилась. Изменились и люди - общество стало жить в очень странной системе, гибриде тоталитаризма и кастовой системы. Уровень человека в обществе определялся его цветовосприятием - чем больше цветов видел человек - тем выше было его положение. Завязка - "красный" парнишка полюбил "серую" чувиху.

Станислав Лем- "Магелланово Облако" - хорошо. Очень душевный и тёплый Ранний Лем. Не сколько про космос, сколько про любовь, чувства, человека и общество в целом.

Иван Панкратов - "Бестеневая лампа" - отлично. Книга про личную жизнь врача-хирурга. Удивительно легко читается и дивным образом затягивает.

Иван Панкратов - "Режим ожидания" - хорошо. Киберпанк про любовь и ревность.

Грег Иган - "Карантин" - отлично. Киберпанк про роль наблюдателя и переносе квантовой механики в макромир.

Леонид Кербер - "Туполевская шарага" - отлично. Короткий рассказ про чудовищные 30-е годы прошлого века, в частности про работу авиаконструкторского ЦКБ-29. Рекомендую.

Генри Марш - "Не навреди" - отлично. Автобиографическая история британского нейрохирурга.

Бен Рич - "Skunk Works: Личные мемуары моей работы в Локхид" - отлично. Книга авиаконструктора о работе в закрытом секретном авиаконструкторском бюро под названием Skunk Works. Именно там были созданы самолёт-шпион U-2, "невидимка" F-117 и сверхскоростной SR-71. Пока это - лучшая книга, которую я прочитал в 2019 году. Рекомендую.

__
 
 
 
Хвостат Хвостатыч
18 April 2019 @ 08:49 pm
Всех причастных - с днём радиолюбителя!

73!

__
 
 
Хвостат Хвостатыч
13 April 2019 @ 09:58 pm
Как вы знаете, ваш старый знакомый делает разные электронные штуки.
Получается весьма неплохо.

Столкнулся с известной проблемой - с каждым годом детали становятся все меньше и меньше.
Покуда фабрикатор еще не купил - прототипы делаю вручную. ;)
И вот с этими самыми деталями надо как-то проводить различные манипуляции.
А чтобы манипуляции проводить, эти детали, для начала, надо хорошо ВИДЕТЬ.

Стал искать бинокулярную лупу.

Зашел в несколько специализированных радиомагазинов.
Но там мне предложили настолько остервенелый хентай китай, что его не то что надевать на голову - даже в руки брать противно.

Стал искать дальше.
И нашел!
Внезапно, в магазине ДЛЯ СТОМАТОЛОГОВ.

Вот такого шикарного корейца:

(кликабельно)

Они есть очень разные, на любой вкус и кошелёк: различная кратность, рабочий отрезок, угол зрения, крепеж на голову, свет итд итп.
Кто тискает радиоэлектронику - очень рекомендую!

__
 
 
 
Хвостат Хвостатыч
13 April 2019 @ 07:41 pm
Дебилы сракорукие:

"Компания Microsoft сообщила пользователем электронной почты Outlook.com о том, что хакеры получили доступ к «ограниченному» числу аккаунтов"

https://techcrunch.com/2019/04/13/microsoft-support-agent-email-hack/

__
 
 
Хвостат Хвостатыч
29 March 2019 @ 02:19 pm
О, моя цитата всё-таки попала на башорг и даже заработала неплохой рейтинг:

Собрался в отпуск. Чувствую: уеду, и что-то ну обязательно сдохнет.
Проверил сервера, массивы, диски, БП.
Маршрутизаторы, коммутаторы.
Всё ОК. Со спокойной душой уехал.
В первый же день отпуска позвонил начальник: сдохла контора.

https://bash.im/quote/455140

__
 
 
 
Хвостат Хвостатыч
22 March 2019 @ 11:48 pm
Сегодня прошел год, как я, после долгих размышлений, всё–таки забрал этого чудесного красавца.

Красавец на сегодняшний день выглядит вот так:


С "котомамой" и "котопапой" дружим.
Говорят, "усыновил кота как родного!"

__
Tags:
 
 
 
Хвостат Хвостатыч
14 March 2019 @ 04:18 pm
Сегодня, оказывается, день числа Пи!

__