Хвостат Хвостатыч (hvostat_hvostat) wrote,
Хвостат Хвостатыч
hvostat_hvostat

Два режима работы с vlan в SRX.

Есть порт в который приходят несколько vlan-ов.
Задача: вонзиться в каждый из них и маршрутизировать/коммутировать кадры и пакетики туда и оттуда.



Вариант №1 "vlan-tagging":
Конфигурируем всё прям на порте, там же и задаём IP-адреса:
[edit interfaces fe-0/0/0]
vlan-tagging;
unit 2 {
description ISP-Contoso;
vlan-id 2;
family inet {
address 10.10.10.10/24;
}
}
unit 3 {
description ISP-Adatum;
vlan-id 3;
family inet {
address 11.11.11.11/24;
}
}
unit 5 {
description INTERNAL;
vlan-id 5;
family inet {
address 192.168.3.24/24;
}
}

Вариант №2 "trunk":
Конфигурируем порт:
[edit interfaces fe-0/0/0]
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members [ Shmel ShitCom Internal ];
}
}
}

Конфигурируем vlan-interface-ы:
[edit interfaces vlan]
unit 2 {
description ISP-Shmel;
family inet {
address 10.10.10.10/24;
}
}
unit 3 {
description ISP-ShitCom;
family inet {
address 10.11.11.11/27;
}
}
unit 5 {
description "Internal";
family inet {
address 192.168.0.0/24;
}
}

Конфигурируем vlan-ы:
[edit vlans]
ShitCom{
description ISP-ShitCom;
vlan-id 3;
l3-interface vlan.3;
}
Shmel {
description ISP-Shmel;
vlan-id 2;
l3-interface vlan.2;
}
Internal {
description "Internal";
vlan-id 5;
l3-interface vlan.5;
}



Очень рекомендую в конфигурации vlan-ов придерживаться правила "номер виртуального интерфейса = номер vlan-а".
_
Tags: juniper, junos, vlan
Subscribe

  • "15 декабря"

    Чем хорош, казалось бы, обычный день - 15-е декабря? Ну, кроме того, что это - международный день чая. А хорош он тем, что в любой нормальной™…

  • "Как восстановить VMFS Datastore после перенастройки RAID?"

    Проблема: После изменения настроек RAID-адаптера, VMWare ESXi 6.7 "потеряла" datastore. Решение тривиальное: 1) Включаем SSH 2) Вваливаемся в…

  • "WD Red с SMR"

    Жесткие диски WD Red с SMR - говно. Краткое резюме: "В ПОМОЙКУ!". Подробнее и с тестами читать тут:…

  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 4 comments